Click for Mag Bay Click for Lurssen Click for Seacoast Click for Oceanco Click for Stats

Technomar 90 with Arneson Drive Furuno AP rudder reference bad

Discussion in 'Technical Discussion' started by marinemods, Nov 10, 2018.

You need to be registered and signed in to view this content.
  1. marinemods

    marinemods New Member

    Joined:
    Aug 1, 2018
    Messages:
    4
    Location:
    Miami, FL
    I am getting incorrect rudder reference indication on both the Furuno NavPilot LCD Display and Analog Display. They read the same but it seems there are dead spots when turning stb to port and back. I am assuming it is the Rudder reference sensor however I am unable to locate the sensor. The boat has Arneson drives. Anyone have any idea where the rudder ref signal comes from?
  2. T.K.

    T.K. Senior Member

    Joined:
    Jan 31, 2007
    Messages:
    910
    Location:
    Cairo - Egypt
    The rudder reference sensor will certainly be on the rudder table, either fitted to a steering arm between both rudders or fitted to one of the rudder actuators if your rudders are not connected together with a steering arm.
  3. marinemods

    marinemods New Member

    Joined:
    Aug 1, 2018
    Messages:
    4
    Location:
    Miami, FL
    These are Arneson Surface Drives (no rudders). From what I understand any sort of trim sensors are connected via mechanical cable to the inside engine room.
  4. marinemods

    marinemods New Member

    Joined:
    Aug 1, 2018
    Messages:
    4
    Location:
    Miami, FL
    Moving along ... found what I am assuming is the turn position indicator made by twin disc p/n 1020316. It is essentially a geared 2K Pot center tap. I found one of the wires lose when I connected it it goes 20 Deg Port when I am hard Stb and center is right on 0. It look's like someone has been in the unit and played with it. Does anyone have any documentation on this? TIA

Share This Page