Click for Burger Click for Nordhavn Click for JetForums Click for Lurssen Click for United

Norpro genset 3LD1GA02

Discussion in 'Generators' started by Sonny Smith, Apr 14, 2015.

You need to be registered and signed in to view this content.
  1. Sonny Smith

    Sonny Smith New Member

    Joined:
    Apr 14, 2015
    Messages:
    2
    Location:
    Port O'Connor
    I am having problems with my genset shutting down after running a few seconds. I have no problem starting it but after running for about 10-12 seconds it will shut down. I do not feel that it is the shut down sensors in that it does run for the few seconds. It will start right back up after the shut down. Any ideas where to start searching for the problem?
  2. Pascal

    Pascal Senior Member

    Joined:
    Feb 29, 2008
    Messages:
    4,988
    Location:
    Miami, FL
    Which Norpro is that? I have an 16kw with Isuzu engine on my boat and it has an electronic timer which activates the oil and temp safety switch after a few seconds. If that fails, the. Th unit will shut down right away.

    Or it could be either of th safety switches, oil press or temp. I replaced the oil switch once.

    You can test it them by bypassing them, I just don't rememenr off hand if you need to ground them or open them
  3. Sonny Smith

    Sonny Smith New Member

    Joined:
    Apr 14, 2015
    Messages:
    2
    Location:
    Port O'Connor
    I am not at all sure what it could be, it is working fine now. If and when it does it again I will check it further.
    Thanks , Sonny
  4. Capt J

    Capt J Senior Member

    Joined:
    Jul 11, 2005
    Messages:
    12,071
    Location:
    Fort Lauderdale
    It is most likely a shut down switch that is going bad. So long as it has oil pressure, 10-12 seconds is too fast for it to overheat even if it had no water flow.