Click for Ocean Alexander Click for Nordhavn Click for JetForums Click for Walker Click for Mag Bay

no water pressure

Discussion in 'Carver Yacht' started by merk, Jun 21, 2016.

You need to be registered and signed in to view this content.
  1. merk

    merk New Member

    Joined:
    Jun 21, 2016
    Messages:
    6
    Location:
    sacramento, ca
    Have a 94 370 aft, radon out of water when facet was left on, filled water tank back at dock, but no water will run. Not sure if water pump quite or filters clogged. Any ideas?
  2. NYCAP123

    NYCAP123 Senior Member

    Joined:
    Mar 14, 2008
    Messages:
    8,889
    Location:
    Long Island, NY
    Could be an air lock, but most likely your pump is toast.
  3. merk

    merk New Member

    Joined:
    Jun 21, 2016
    Messages:
    6
    Location:
    sacramento, ca
    That's what I'm thinking, I'll check the air lock idea, thanks
  4. Capt J

    Capt J Senior Member

    Joined:
    Jul 11, 2005
    Messages:
    11,859
    Location:
    Fort Lauderdale
    If the pump ran dry it is most likely toast. Hook up your dockside water and see if you have waterflow.....if that's the case I'd be looking at the pump.
  5. merk

    merk New Member

    Joined:
    Jun 21, 2016
    Messages:
    6
    Location:
    sacramento, ca
    I did try that and no problem there, ran just fine. Disconnected the hose and tried it like if it was out anchored and no luck. Thinking I might have fried pump. Thanks
  6. Pascal

    Pascal Senior Member

    Joined:
    Feb 29, 2008
    Messages:
    4,850
    Location:
    Miami, FL
    How long was the pump running dry? What kind of pump ? Is it running (making noise)?

    Most pumps will survive a run dry episode but who knows what you have. In 20+ years it must have been replaced, so even if someone as the very same boat, you can't be sure they don't have a different pump

    Air locks are rare on DC fresh water pressure pumps are they are always self priming

    Did you check the breaker? Could there be an inline fuse? Is the pump making a sound
  7. merk

    merk New Member

    Joined:
    Jun 21, 2016
    Messages:
    6
    Location:
    sacramento, ca
    I haven't gotten down into area where pump is to listen, but did get sputtering water -air coming out. When filled up water container, nothing came out, just dead. Don't know what kind of pump it is, had the boat for a year now so don't know history on pump. Thanks
  8. Capt J

    Capt J Senior Member

    Joined:
    Jul 11, 2005
    Messages:
    11,859
    Location:
    Fort Lauderdale
    Are you still getting sputtering and air? I would locate the water tank in the vessel, it should be pretty much below where the deck fill is located (inside the vessel). Start filling the tank. Now follow the hoses and the 3/4" +/- hose should be going to the water pump, locate that. If the pump is running, the water tank is full, and you're getting air and sputtering out of the faucet, I would look for an air leak in the hose between the tank and the pump.
  9. merk

    merk New Member

    Joined:
    Jun 21, 2016
    Messages:
    6
    Location:
    sacramento, ca
    Thanks, I'm going out to the boat in a bit, I'll check that out.
  10. gcsi

    gcsi Member

    Joined:
    Mar 18, 2011
    Messages:
    48
    Location:
    tampa
    Try this, it works for me....
    Turn off pump and dock water supply. Open all valves (shower, sinks, etc...), after system is completely de pressurized, turn on pump. In my boat, there is a check valve upstream of the DC water pump. The "dry" pump cannot build enough pressure to overcome system pressure. Releasing all pressure, then starting pump overcomes issue on my particulat setup.
  11. merk

    merk New Member

    Joined:
    Jun 21, 2016
    Messages:
    6
    Location:
    sacramento, ca
    Thanks to all, the pump does work, just had to let it build up enough pressure and water runs fine. But do have a leak in a line some where. When I turn on switch for water, pump seems to run all the time, and I can see water coming into front galley bilge pump cavity, coming in thru front stringer hole. Looking for it right now. Thanks