Click for Cheoy Lee Click for Nordhavn Click for Llebroc Click for Mag Bay Click for Walker

Kohler 6.5 genset issues

Discussion in 'Generators' started by dabluzdude, Aug 27, 2016.

You need to be registered and signed in to view this content.
  1. dabluzdude

    dabluzdude New Member

    Joined:
    May 25, 2016
    Messages:
    4
    Location:
    Alabama
    1991 era 6.5 Kohler genset. Cranks easily, runs very smoothly for about 40 minutes under load, then dies. Good waterflow. Will crank immediately after it dies and runs smoothly for about 10-12 minutes, then dies. Does this regardless of load. I would think that a temp issue would prevent it from re-cranking right away as it would still be hot. oil level fine. ideas? thanks in advance.
  2. Capt J

    Capt J Senior Member

    Joined:
    Jul 11, 2005
    Messages:
    13,051
    Location:
    Fort Lauderdale
    Check the water temp with an infra red. Does it have an oil pressure gauge and water temp gauge? If water temp and oil pressure are ok then my guess is you've got a bad shutdown sender (ie oil pressure, exhaust temp, coolant temp, etc). you're going to have to ohm each sender and see which one is bad.
  3. CSkipR

    CSkipR Member

    Joined:
    Aug 16, 2008
    Messages:
    947
    Location:
    New Smyrna Beach, Fl
    I had a similar problem and it was the fuel pump. Mechanic asked me how old the fuel pump was and I said original 10yrs. He said change it and that will fix your issue. It did. Mine would run for different times as much as 3 hrs and then shutdown. Then I would restart, it would run for awhile and shutdown again.
  4. dabluzdude

    dabluzdude New Member

    Joined:
    May 25, 2016
    Messages:
    4
    Location:
    Alabama
    thanks all for the insight