Click for JetForums Click for Abeking Click for Cross Click for Lurssen Click for Mag Bay

Fault code Volvo Penta D4

Discussion in 'Technical Discussion' started by Noblige, Jan 30, 2016.

You need to be registered and signed in to view this content.
  1. Noblige

    Noblige New Member

    Joined:
    Jan 27, 2016
    Messages:
    5
    Location:
    Norway
    image.jpg image.jpg Hi
    I got a fault code on my Volvo Penta D4 300 Hp 2012 model 200 running hours: MID 128 PSID 53 FMI 0

    The engine only gets 1600 Rpm.

    The engine is also a bit harder to get started.

    Can it be fuel pressure sensor or MPROP ?
    Have anyone had the same issue?

    I also got an Inactive fault code. How do I delete that?

    See attached pictures from EVC panel.

    Regards Stein Norway
    Last edited: Jan 30, 2016
  2. Capt Ralph

    Capt Ralph Senior Member

    Joined:
    Sep 8, 2004
    Messages:
    9,204
    Location:
    Satsuma, FL
    So
    A half day later, everybody is wondering but not asked.
    Seems I have to;

    Have you looked into your maintenance manual or asked your Volvo rep yet?
  3. Noblige

    Noblige New Member

    Joined:
    Jan 27, 2016
    Messages:
    5
    Location:
    Norway
    The Volvo Rep was not to shure, but "Thought" it mighg be the pressure sensor. I have already ordered one. I was just curious if anyone else have had the excact same problem.
    Thanks
    Stein
  4. Capt J

    Capt J Senior Member

    Joined:
    Jul 11, 2005
    Messages:
    13,400
    Location:
    Fort Lauderdale
    Have you checked your fuel filters??? Fuel filters are usually the first cause of performance issues with a diesel.
  5. Ken Bracewell

    Ken Bracewell Senior Member

    Joined:
    Feb 9, 2006
    Messages:
    1,455
    Location:
    Somewhere Sunny
    I'm sure you can download the service manual, and those codes will become clear.
  6. Noblige

    Noblige New Member

    Joined:
    Jan 27, 2016
    Messages:
    5
    Location:
    Norway
    Fuel filters have been changed. So they are new. Waiting for the fuel pressure sensor, that will arrive in a couple of days. If the sensor is faulty, it might give the wrong signal to the High pressure pump and the MPROP(pop off valve) will maintain open. I Will get it changed and let you guys know how it went
  7. Noblige

    Noblige New Member

    Joined:
    Jan 27, 2016
    Messages:
    5
    Location:
    Norway
    Hi again.
    Changed pressure sensor 3843100, and ALL GOOD!!!
    Just in case anyone else has the same problem/alarm,........

    Stein
    Norway
  8. JJ Demajo

    JJ Demajo New Member

    Joined:
    Mar 10, 2016
    Messages:
    3
    Location:
    Malta
    Maybe someone can help me with my issue which is similar.

    I have one of the Volvo Penta D4 300HP (2009 model with 280 hrs) giving me an error. Error is as follows - MID 164 SPID 231 FMI 2 - Photo attached

    The engines are showing now signs of any problems. Start and run smoothly for about 40mins and then this error is shown on the engine panel and a caution light. The engine keep running smoothly with no visible symptoms. No over heating and no low voltage.

    Would appreciate your assistance.
    Thank you

    Attached Files:

  9. Noblige

    Noblige New Member

    Joined:
    Jan 27, 2016
    Messages:
    5
    Location:
    Norway
    Send me your email adress:) I have got the fault code reigister.
  10. JJ Demajo

    JJ Demajo New Member

    Joined:
    Mar 10, 2016
    Messages:
    3
    Location:
    Malta
    sent in a private conv. thank you for your quick reply.
  11. JJ Demajo

    JJ Demajo New Member

    Joined:
    Mar 10, 2016
    Messages:
    3
    Location:
    Malta
    Hi Noblige.... the document you sent over to doesnt seem to have the fault i am looking for. Is there another document? or does any one else have a suggestion what the fault could be?

    thank you :)
  12. Fishtigua

    Fishtigua Senior Member

    Joined:
    Jul 20, 2007
    Messages:
    2,768
    Location:
    Guernsey/Antigua
    There's pretty much one answer, get a Volvo tech to plug his Vodia unit in and do a check. You can do your own checks but it involves buying a knock-off Vodia for $1.5k from China.

    Oh, and Noblige, I could have told you it was that sensor as they always go. Sorry I've been away for a while from YF but some d*ckhead was really annoying me on the site.
  13. Daniel Gauci

    Daniel Gauci New Member

    Joined:
    Aug 8, 2020
    Messages:
    1
    Location:
    Malta
    Hi, I have a similar issue to JJ Demajo. MID 164 SPID 231 FMI 2. But the symptom is that the actuator shift gear is not working. Can anyone help please?