List Your Boat Click for Llebroc Click for Glendinning Click for Mag Bay Click for Cross

Cruisair KRA025 Condensing Unit Issue (Not Cooling)

Discussion in 'HVAC' started by Soulstice, Mar 17, 2021.

You need to be registered and signed in to view this content.
  1. Soulstice

    Soulstice Member

    Joined:
    Apr 1, 2013
    Messages:
    129
    Location:
    Portsmouth, Ri
    At the end of last season, I had a problem with my cockpit freezer not cooling on the Post which is cooled by a Cruisair KRA025 Condensing Unit. The AC pump is brand new, all of the raw water lines have been cleaned, and the raw water supply pressure was verified. As I dug into troubleshooting it, I was thinking it might be the Constant Pressure Valve (CPV) however since this is pretty tough to get to, I wanted to check some other possibilities first. The sightglass for the condensing unit (see attached picture) is clear and the colored media is yellow which from the manual indicates moisture in the system and possible lack of coolant. This is my first time troubleshooting this unit and I was wondering if I am reading this correctly. Anyone have this issue before? Should I try to add coolant first or does this appear to be a moisture contamination issue?

    IMG_6511 (1).jpg
  2. ChiTown

    ChiTown Member

    Joined:
    Mar 22, 2019
    Messages:
    69
    Location:
    Chicago
    Looks like your both contaminated and low on charge. Best to put a set of gauges on to verify. You might have a leak which a good tech can locate and repair, and you might need a new drier/filter.
  3. Soulstice

    Soulstice Member

    Joined:
    Apr 1, 2013
    Messages:
    129
    Location:
    Portsmouth, Ri
    Thank You, that is what I was leaning to. I will give the local guys a call.