Click for Mulder Click for Perko Click for Nordhavn Click for YF Listing Service Click for Walker

2015 sea ray 510 sundancer coolant loss question

Discussion in 'Sea Ray Yacht' started by john1999, Apr 19, 2021.

  1. john1999

    john1999 New Member

    Joined:
    Dec 18, 2020
    Messages:
    20
    Location:
    33067
    am losing about 18 oz an hour of coolant in the reservoir,no fluid in the bilge.
    qsc 550 cummings with approx 1000 hours. recent heat exchanger and aftercooler service done by seller.boat is new to me.any ideas where coolant might going?
  2. DOCKMASTER

    DOCKMASTER Senior Member

    Joined:
    Feb 26, 2012
    Messages:
    1,464
    Location:
    Ketchikan, Alaska
    Both engines or one side only? I assume one side only. Pull your oil dipstick to make sure the coolant isn't getting into the oil path. If not there, likely going out the exhaust. It could be leaking onto a hot area like an exhaust manifold and evaporating. But if this were the case you would likely get a strong coolant odor in the engine room.
  3. Capt Ralph

    Capt Ralph Senior Member

    Joined:
    Sep 8, 2004
    Messages:
    13,087
    Location:
    Satsuma, FL
    Why was the H/E serviced and who did it? Rodded by a radiator gorilla or somebody with a clue?
    You have a problem Houston. Hopefully It's not in the after-cooler, just the H/E and out the exhaust.
    Pull the after end cover off of the H/E and pump up the coolant side to 8psi max. You will see coolant come from the rods.

    Was any of this discovered (or hinted) on your purchase survey?
    Last edited: Apr 19, 2021
  4. john1999

    john1999 New Member

    Joined:
    Dec 18, 2020
    Messages:
    20
    Location:
    33067
    not uncovered during survey,thanks for the advice have called sun power in ft laud to access problem.
  5. DOCKMASTER

    DOCKMASTER Senior Member

    Joined:
    Feb 26, 2012
    Messages:
    1,464
    Location:
    Ketchikan, Alaska
    Sorry to hear. Please let us know what you find.