Click for Stats Click for United Click for EMP Click for Bering Click for Lurssen

Overheating 671ti

Discussion in 'Post Yacht' started by Posterboy91, May 21, 2018.

You need to be registered and signed in to view this content.
  1. Posterboy91

    Posterboy91 New Member

    Joined:
    Oct 17, 2017
    Messages:
    13
    Location:
    Fort Lauderdale fl
    i have a starboard DD 671ti engine that overheated at cruise and went to 240 very quickly with the port remaining at 165. The heat exchangers were replaced 2 years ago so I am curious what else could be causing this issue and also since the Motor went that hot in temp what do I have to worry about now. I can say as soon as I took it to idle and out of gear it cooled off instantly. Thoughts?
  2. Capt Ralph

    Capt Ralph Senior Member

    Joined:
    Sep 8, 2004
    Messages:
    5,523
    Location:
    Jax FL
    You picked up some trash or the impeller is failing (or both).
  3. porthole

    porthole Member

    Joined:
    Mar 15, 2016
    Messages:
    71
    Location:
    Jersey Shore
    As above.
    I picked up a plastic shopping bag soon as I throttled up leaving Shark River inlet.

    Within seconds I went to overheat, shut down once outside and it cooled down fairly quick.

    Impeller was toast though.
  4. Pascal

    Pascal Senior Member

    Joined:
    Feb 29, 2008
    Messages:
    3,656
    Location:
    Miami, FL
    240 is very hot, I wouldn't be surprised if you have damage. Check the oil and coolant level carefully, as well as exhaust hoses. If you lost raw water flow long enough for coolant to get to 240, there is likely exhaust damage. Don't you have exhaust exhaust temp alarms?

    Check the impeller, strainer etc. when you start that engine check the pump cover to make sure it stays cool
  5. My Affair

    My Affair Member

    Joined:
    May 23, 2006
    Messages:
    83
    Location:
    Mystic, CT
    How often do you replace your impellers? If your impeller broke up make sure to find all the pieces. Did your over temp alarms go off?
  6. ruby

    ruby Member

    Joined:
    Apr 22, 2012
    Messages:
    230
    Location:
    Long Island
    Check your transmission coolers also, all kinds of things may be in there, I cleaned my transmission coolers every 2 years
  7. Capt Ralph

    Capt Ralph Senior Member

    Joined:
    Sep 8, 2004
    Messages:
    5,523
    Location:
    Jax FL
    Any update from the OP?

Share This Page