Click for DeAngelo Click for Bering Click for McConaghy Click for Pacific Mariner Click for Nordhavn

Meridian 381 Thrusters

Discussion in 'Technical Discussion' started by Newportsailor, Nov 5, 2009.

  1. Newportsailor

    Newportsailor New Member

    Joined:
    Nov 4, 2009
    Messages:
    2
    Location:
    Newport Beach
    I've been having problems with my thrusters. For awhile they were really weak..and now they just stopped working. Any ideas?
  2. Pascal

    Pascal Senior Member

    Joined:
    Feb 29, 2008
    Messages:
    2,408
    Location:
    Miami, FL
    start with checking the power source... do they have dedicated batteries? if so , how are they charged? check the connections for corrosion, loose wires including those at the switches.

    if they dont have dedicated batteries, see what they run off? house bank? start bank? check voltage with the thruster off, then as someone turns them off and see how bad it drops.

    that said, coffee grindders on a 40 footer are completly uncessary except in really bad docking situations.
  3. Henning

    Henning Senior Member

    Joined:
    Sep 22, 2009
    Messages:
    942
    Location:
    Ft Lauderdale FL
    Back in the day we didn't even get thrusters on 160s, the Halter 185s were the smallest boats that had thrusters. The other day I saw a 26' boat on a trailer with a thruster....:rolleyes:

    That said, Pascal has it right, you most likely have a dedicated battery for it and the charger is turned off/breaker tripped.
  4. NYCAP123

    NYCAP123 Senior Member

    Joined:
    Mar 14, 2008
    Messages:
    8,020
    Location:
    Long Island, NY
    Murphy's Law dictates that if you use thrusters in place of skill they will fail when you need them most. Worse still, I get the impression that you're using both bow AND stern thrusters. You've probably drained the batteries, but you may have simply worn out those motors. Do they go weak or die or do they simply not have the desired grab. You may also have damaged or loosened the blades. Use the thrusters sparingly.
  5. Newportsailor

    Newportsailor New Member

    Joined:
    Nov 4, 2009
    Messages:
    2
    Location:
    Newport Beach
    Yes it was working very weak at first and now it doesn't work at all. As far as I know it has dedicated batteries and the levels are fine in them. We were using both....the spot is kind of tight but personally I can get it in just fine, but not everyone has the same comfort level as me. Its actually a friend of mine's boat and he asked if I could help do a little research on the problem.
  6. Capt J

    Capt J Senior Member

    Joined:
    Jul 11, 2005
    Messages:
    6,284
    Location:
    Fort Lauderdale
    Chances are the battery(s) for the thrusters is shot. Check the water level in those batteries, but a lot of times the water gets low and then you lay on them and short out a cell in the battery and it's done.......

Share This Page